>: CG Forums on 3dtotal - The best forums for CG artists :.
threedy forums home
 


top-table-gradient
Go Back   3DTotal Forums > Help, Advice and Chat > Animation & Rigging Help
bottom-table-gradient

Reply
 
Thread Tools Display Modes
Old 03-01-2013, 03:32 PM   #1
Caz2005
Registered User
 
 
Join Date: Aug 2006
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Question Maya rig warps all over the place when moved

Hi there,

I'm making this Octopus rig for UNI in Maya 2011. All has been going very well until I tried moving the rig last night. As you can see from the pictures when the whole rig is moved the spine rotates ans contorts.



I think the problem is the spine as when I delete the IK and clusters etc the rig moves without the ontortions. I'm at my wits end with this and have to finalize it by the 10th. Hope someone out there can help me.

Cheers
Caz2005 is offline   Reply With Quote
Old 03-01-2013, 09:55 PM   #2
poopipe
conscientious objector
 
poopipe's Avatar
 
 
Join Date: Sep 2007
Location: cambridge, uk
Posts: 4,323
Thanks: 3
Thanked 130 Times in 124 Posts
Awards Showcase
Threedy Top Poster - Gold: Contributing to the forums with 2,000+ posts - Issue reason: too much free time Threedy Top Poster - Bronze: Contributing to the forums with 100+ posts - Issue reason: Target reached! Threedy Top Poster - Bronze: Contributing to the forums with 100+ posts - Issue reason: Target reached! The Golden Eye: Producing art worthy of being linked from the frontpage of either forums or 3DTotal.com - Issue reason: he finished The Golden Grenade III: For participating in the Dominance War III and successfully finishing, well done soldier! - Issue reason: I finished Dominance War 3 Thumbs up!:  - Issue reason:  Thumbs up!:  - Issue reason: For doing a great job in helping out! Low Poly Game Art - Gold: Winner of a low poly challenge! - Issue reason: For Excellence at Low Poly Art - Well Done! Low Poly Game Art - Gold: Winner of a low poly challenge! - Issue reason: For Excellence at Low Poly Art - Well Done! 
Total Awards: 9
it'll be down to the space the ik controller thinks its in i should imagine

sadly i don't know enough about maya controllers to give you a fix
__________________
work pigs!!


http://johnsarthole.blogspot.com/
poopipe is offline   Reply With Quote
Old 03-01-2013, 10:17 PM   #3
Caz2005
Registered User
 
 
Join Date: Aug 2006
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Hi there, thanks for the reply.

I'm beginning to suss out the problem. It seems to be down to the heirarchy. I've now got the whole rig moving via a controller as it should except from the Spine which stays put, it doesn't move at all. I noticed that the Spine curve clusters had become un-parented so I parented them up with their controllers and the result I got was the same problem as the pictures in my first post show.

I've no idea how to get around this
Caz2005 is offline   Reply With Quote
Old 05-01-2013, 10:48 AM   #4
Caz2005
Registered User
 
 
Join Date: Aug 2006
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Anyone?
Caz2005 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 04:30 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
all images displayed on this site are copyright the original artists and may not be reproduced, copied or published elsewhere without their express permission